Back to overview
Resolved
Some services are down
Jul 2, 2026 at 8:37am UTC
Affected services
API
Data Service
Resolved
Jul 2, 2026 at 8:37am UTC
Elevated latency and packet loss on Edge Network in US regions
Traffic continues to route around the affected upstream fiber provider following our earlier reroute. We are seeing conditions in US regions improve, but latency and packet loss have not fully returned to baseline, and cross-region private networking may still be intermittent.
We are continuing to work toward full recovery and are monitoring closely.
Affected services